System Requirements

To use the Customer Portal, the following is required:

>   Internet Explorer 7.0 or higher
>   Pop-up blockers should be disabled